If a specific page on a site doesn't load for some reason or if a link is broken, the site visitor shall see an error page with a generic message. The page will have nothing in common with the rest of the website, that could make the visitor leave the site. A likely solution in such a case is a feature made available from some web hosting companies - the option to set your own personalized error pages that will have the same design and style as your website and which could contain any text or images which you want dependent upon the particular error. There are four well-known errors that can occur and they involve the following so-called HTTP status codes - 400, when your world-wide web browser sends a bad request to the server and it cannot be processed; 401, in case you are supposed to log in to see a web page, but you have not done this yet; 403, if you do not have a permission to see a specific page; and 404, if a link which you've clicked leads to a file which doesn't exist. In any of these cases, visitors shall be able to see your customized content instead of a generic error page.

Custom Error Pages in Shared Hosting

If you obtain a shared hosting from us, you'll be able to set customized error pages for your sites fast and easy, since this feature is a part of all of our plans. Once you've created the files and uploaded them to your website hosting account, you can check out the Hosted Domains section of your Hepsia Control Panel and click on the Edit button for the specific domain or subdomain. Inside the pop-up that will show up, you will see drop-down menus for all four sorts of errors and for each one of them you can choose an Apache default page, a generic page from our system or a custom made page. Should you select the third option, you should only enter the URL to the file that you have uploaded then save the change. A different way to set customized error pages is to set up an .htaccess file in the domain or subdomain folder and to add a couple of lines of program code in it. If you don't have previous experience or if you're simply uncertain how to do that, you may simply copy and paste the code from our Knowledge Base article on that subject.

Custom Error Pages in Semi-dedicated Hosting

If you host your web sites in a semi-dedicated server account from our company, you may set tailor-made error pages for any of them with ease using our in-house built Hepsia hosting CP. With several mouse clicks in the Hosted Domains section, you could change the default setting from a system page to a custom made one for each of the four error types. All you must do is provide a link to every single file which you have uploaded before that and then save the change. If needed, you will be able to revert this modification whenever you want and in exactly the same way. If you'd like, you can use an .htaccess file as well. It has to be created/uploaded in the domain or subdomain folder belonging to the site whose error pages you intend to alter and the content for such a file can be found in our Help article on this matter.